ReCycle 2.1 crashes on Mac OS X 10.5 Leopard

ReCycle 2.1 has limited compatibility with Mac OS X 10.5 Leopard. It will not run on computers with more than one processor, regardless of whether it is a PowerPC or Intel Mac- This issue has been solved in the latest update of ReCycle, available as a free download here.