Propellerhead Forum

Propellerhead Forum (
-   General Forum (read only) (
-   -   Record 1.5 problem - can't authorize! (

Pat303 2010-09-03 13:54

Record 1.5 problem - can't authorize!

I've already raised an email about this with the Props Support, but thought I'd also post here in case anyone is having the same problem. I've read a number of threads about installing and authorizing the recent Record 1.5 upgrade, but none describe the same problem I'm encountering here - hence the new thread.

Ok, so here's my problem...

Until yesterday I had only Reason (and ReCycle) installed on my desktop iMac (3 GHz Intel Core i3, OS 10.6.4). I had recently updgraded to Reason 5, which runs perfectly fine.

So yesterday I bought a copy of 'Record for Reason owners'. I installed it (Record version 1.0) and then authorized/registered the software to my Props account using the start-up 'Authorization Window' wizard. Record 1.0 opens fine when clicked, but I realise that I now have to upgrade to Record 1.5 in order to make it compatible with Reason 5.

So I delete the Record 1.0 folder from my computer (as instructed) and install the Record 1.5 update in its place.

Now, when I run Record it takes me to the start up window (same as when I first booted up Record 1.0) and asks whether I want to 1) authorize and register; 2) log-in to run without the ignition key; or 3) run in demo mode.

I click the authorization button and I'm asked to input my Record license number, which I do. I'm then told that I must first register Reason and am taken to a similar page, which asks for my Reason license number and registration code. I enter the details and then an error message appears, telling that my copy of Reason is already registered - well I know that, because it's registered to me!

So in short: I'm unable to open and run the Record 1.5 update because I can't get passed the start-up wizard - which continues to ask me to register Record and Reason, even though both of these softwares are clearly registered on my Props account page and authorized on my ignition key.

Anybody got any ideas for a fix - or encountering the same problem?

To be clear: my account page shows that my copies of Reason 5, Reason 4 and Record are all registered to me. It also shows that my Record ignition key is authorized for my licensed copies of Reason 5 and Record.

I could try deleting and re-installing the software, but this seems to be a problem with registration and not the product itself.

Thanks in advance for any feedback.

PS: needless to say, this is damn frustrating!

3rdFloorSound 2010-09-03 14:04

when I did this I had to register/authorize the programs in 2 separate sessions.
I opened reason and registered that on the site, then had to sign out or leave the site. Then I closed reason and opened record, used the authorizer to -- I think it said "launch browser?" It took me back to the prop site with a new session and I was able to complete the process that way.

Pat303 2010-09-03 16:43

^ Cheers for the tip.

The problem I have is that the set-up wizard for Record keeps trying to register my copy of Reason, which is already registered (to me!). I.e. - there's an error in my authorization process that causes it fail at the point of registering Reason.

However, I've since noticed (this morning) that a new registered account for Record 1.5 has appeared on my 'accounts' page - previously I only had one registered account for Record (no version number). Hence, I'm now thinking this could be the cause of my problems last night - i.e. I was trying to boot up Record 1.5 using my Record registration, and not the Record 1.5 account - if that makes sense?

Bear in mind here that the Record 1.5 registration was not listed in my 'registered products' until this morning - so either this is the result of the Props people responding to my support email, or there was some kind of delay over my Record 1.5 registration being recognised on the website.

Whatever...hopefully this means I'll be able to fix the problem and authorize Record 1.5 when I get home after work tonight. If not, then I'm in the hands of the Props support folks!

1976sven 2010-09-03 16:49

try my way

Pat303 2010-09-03 16:52

^ Thanks for this.

I'll try your method if I encounter the same problems when I try booting up Record later tonight (I'm currently at work!).

Knickle 2010-09-03 17:49

I think the problem is that Record 1.0 is looking for Reason 4, not Reason 5. One thing you can try is putting the Reason 4 license on your ignition key. You will have to go to the account section on the site and find your Reason 4 license, and click the manage license link next to it. This will allow you to put the Reason 4 license on the ignition key.

The only part I'm not certain about is whether or not you will get a Record 1.5 license generated as this normally happens when you install the Reason 5 upgrade. I don't know if Propellerhead anticipated that someone would install an older version of Record after upgrading to Reason 5.

Pat303 2010-09-03 18:01

^ Good point; I was thinking the same until this morning when the Record 1.5 license appeared on my 'accounts' page.... last night I'd been mistakenly trying to register and authorise Record 1.0 with Reason 5 (as the Record 1.5 license wasn't showing on my accounts page at the time), which is hopefully what was causing the problem...

Fingers crossed it will recognise the Record 1.5 license when I add this to my ignition key tonight. Otherwise, I guess I'll have to wait for rescue by the Props supports team!

(I totally understand - and support - the need to license and register software, but this is starting to cause me a headache!).

Knickle 2010-09-03 18:13

Let us know if it works.

As far as I know the older versions were supposed to be pulled from the shelves (at least that's what my local music retailer told me). So I'm a little surprized that you were able to buy it. Unless you bought it 2nd hand, in which case it would make sense.

Pat303 2010-09-03 19:25

Ok, I've fixed the problem...!

Turns out I was trying to run Record 1.5 with Record 1.0 on the ignition key (the 1.5 license wasn't available in my profile account until this morning).

I've now authorized Record 1.5 and Reason 5 on the key and Record is running fine and linking perfectly with Reason.

So the moral of the story is: if you're having trouble running the Record 1.5 update, make doubly-sure that you have the correct version of Record authorized on the ignition key! And bear in mind that it took a couple of days before my Record 1.5 license appeared on my accounts page after registering Reason 5, so you might need to be patient (as I'm clearly not!).

Thanks again to those of you who offered advice here, which was greatly appreciated :-)

Right, now I'm off to make some noise...

KATIELOGO 2010-09-06 02:02

i'm having the EXACT SAME PROBLEM, paid for both Reason 5.0 and Record 1.5 and my ignition key has never worked (with record). it totally blows and there is no customer support for this situation AT ALL. i am so irritated. ALL I WANT TO DO IS USE THE SOFTWARE THAT I PAID FOR. but my ignition key is never recognized on my brand new macbook pro OS 10.6.3.

does anyone know what you do if the ignition key never has 'ignited'?.. it flashes red once and i launch the browser but i get an error message that says 'no ignition key is in the usb port' (which it is). i would LOVE ANY HELP.

P.S when i try to register my upgrade to 1.5 i get an error message that says '

Error: The License Number you have entered has already been registered.' (but it is record 1.0)

All times are GMT +2. The time now is 06:50.