Propellerhead Forum

Propellerhead Forum (https://www.propellerheads.se/forum/index.php)
-   Feature Suggestion Forum (https://www.propellerheads.se/forum/forumdisplay.php?f=7)
-   -   Time-Stretch Issue (https://www.propellerheads.se/forum/showthread.php?t=172793)

realismo 2012-12-16 00:29

Time-Stretch Issue
 
I imported a 170 bpm sample into a 130 bpm session, disabled stretch, chopped it up, then wanted to manually stretch some clips. apparently this doesnt work.
so i enabled stretch, all the clips I highlighted automatically stretched to the session tempo in an extreme way. i lost the beautiful sample i chopped. almost as if it reset itself. hard to explain. try it.

i dont want these clips to behave this way. i want to preserve the edits at the original tempo then manually time-stretch. this is not possible. or maybe it is & i am doing this wrong.

I should be able to import a sample, disable stretch, chop it up & reconfigure it, and if it want to then subsequently stretch one of the reconfigured clips using option-click-drag, i should be able to do it w/o the clip going crazy on me and changing my edit.

currently, once you disable stretch, option-click-drag (manual time stretching) is not an option and it has hinderend me greatly when trying to experiment w sample.

take a look at protools. their handling digital audio is pretty simple.

there is no enable or disable stretch. its all done manually.

i think the solution to this would be to keep the enable/disable function in Reason but allow for manual stretching when disabled.

i hope this makes sense. its difficult to put into words. i would suggest going through the above described steps to see what i am talking about. please fix this. i have yet to fully convert over to Reason because of this digital audio issue. and i really want to ditch protools :P

thank you,

p.s. true nudge feature is absolutely necessary.

Monkatron 2012-12-16 01:57

Quote:

Originally Posted by realismo (Post 1199306)
I imported a 170 bpm sample into a 130 bpm session, disabled stretch, chopped it up, then wanted to manually stretch some clips. apparently this doesnt work.
so i enabled stretch, all the clips I highlighted automatically stretched to the session tempo in an extreme way. i lost the beautiful sample i chopped. almost as if it reset itself. hard to explain. try it.

i dont want these clips to behave this way. i want to preserve the edits at the original tempo then manually time-stretch. this is not possible. or maybe it is & i am doing this wrong.

I should be able to import a sample, disable stretch, chop it up & reconfigure it, and if it want to then subsequently stretch one of the reconfigured clips using option-click-drag, i should be able to do it w/o the clip going crazy on me and changing my edit.

currently, once you disable stretch, option-click-drag (manual time stretching) is not an option and it has hinderend me greatly when trying to experiment w sample.

take a look at protools. their handling digital audio is pretty simple.

there is no enable or disable stretch. its all done manually.

i think the solution to this would be to keep the enable/disable function in Reason but allow for manual stretching when disabled.

i hope this makes sense. its difficult to put into words. i would suggest going through the above described steps to see what i am talking about. please fix this. i have yet to fully convert over to Reason because of this digital audio issue. and i really want to ditch protools :P

thank you,

p.s. true nudge feature is absolutely necessary.

I echo this deeply. its SO needed.

flex time is just so amazing. i would love to have this in reason.

plaamook 2012-12-17 00:01

i've posted this somewhere.

i think the trick is to be able to disable the time stamp on audio export in the first place. i, for one, never need it as i work with mostly abstract stuff. and as i use Reason to process recordings a lot, i end up converting WAV's to aif ,etc in order to get rid of the time stamp. which is a pain in the ass.

then there's the disable timestretch issue. i can see why they did it this way, simplicity, and i can see why it needs more flexibility.

so yeah, +1 on any advancements to the handling of audio in reason. clunky as hell.

JiggeryPokery 2012-12-17 00:39

Quote:

Originally Posted by realismo (Post 1199306)
I imported a 170 bpm sample into a 130 bpm session, disabled stretch, chopped it up, then wanted to manually stretch some clips. apparently this doesnt work.
so i enabled stretch, all the clips I highlighted automatically stretched to the session tempo in an extreme way. i lost the beautiful sample i chopped. almost as if it reset itself. hard to explain. try it.

i dont want these clips to behave this way. i want to preserve the edits at the original tempo then manually time-stretch. this is not possible. or maybe it is & i am doing this wrong.

I should be able to import a sample, disable stretch, chop it up & reconfigure it, and if it want to then subsequently stretch one of the reconfigured clips using option-click-drag, i should be able to do it w/o the clip going crazy on me and changing my edit.

currently, once you disable stretch, option-click-drag (manual time stretching) is not an option and it has hinderend me greatly when trying to experiment w sample.

take a look at protools. their handling digital audio is pretty simple.

there is no enable or disable stretch. its all done manually.

i think the solution to this would be to keep the enable/disable function in Reason but allow for manual stretching when disabled.

i hope this makes sense. its difficult to put into words. i would suggest going through the above described steps to see what i am talking about. please fix this. i have yet to fully convert over to Reason because of this digital audio issue. and i really want to ditch protools :P

thank you,

p.s. true nudge feature is absolutely necessary.


It's (probably) functioning as intended. You missed out a vital step in the Reason process: "Bounce Clips to New Recording".

Audio stretch in Reason is non-destructive. From discussions we've had on the forum we think this is because the song file contains the original wave as well as the time-stretched version, so Reason always refers back to the original if you need to restretch it, to maintain the highest fidelity. In your example, you're still using the one wavefile, it's just held in multiple clips.

If you're chopping audio files, always select the clip/s and right-click for the "bounce clips to new recording function". Then you can (I think) select timestretch for each individual clip, that is now a dedicated wave of its own. Took me a while to get used to using that feature, but it's utterly brilliant, and really quick and easy.

Audio quantising is a different thing, and much requested.

p.s: True nudge? not sure what you mean here, but there a numerous nudging shortcuts for clips/notes.


All times are GMT +2. The time now is 14:28.