Propellerhead Forum

Propellerhead Forum (https://www.propellerheads.se/forum/index.php)
-   General Forum (read only) (https://www.propellerheads.se/forum/forumdisplay.php?f=3)
-   -   Reason won't recognise Midi keyboard anymore! (https://www.propellerheads.se/forum/showthread.php?t=182008)

muzicalkat 2013-05-02 09:24

FIXED Reason won't recognise Midi keyboard anymore!
 
Hello everyone :)

I've been using my old Evolution MK-449c (via USB) with Reason for a few years with no problems at all. All the faders and knobs work a treat.

Two days ago, I moved my computer to a different position and in the process, removed all my dongles and USB cables for safety. (I’ve had an accident in the past with a smashed Steinberg Key….)

Since I set back up, Reason 6.5 will not recognise my keyboard. It doesn’t even show that the USB port is available when I try to set it up manually. (BTW, the keyboard works fine in Cubase 6.5 and Ableton LIte).

I have tried changing USB ports, uninstalling and reinstalling drivers....nothing. Reason does not want to acknowledge its existence!

Interestingly, despite Cubase and Ableton recognising the MK-449c, M-Audio's Enigma software also seems to act like it's not plugged in now....

If the info helps, I'm on Windows 7, 64bit and have my Props dongle, Steinberg Key, Korg PadKontrol, computer keyboard/mouse dongle and my Focusrite Saffore 6 USB all plugged in USB ports with no problems. My computer has 10 USB ports available and no USB hubs are used.

Any help or insight would be very grateful received!! I really wanted up upgrade to R7!!

Cheers :)

Ambientdave 2013-05-02 09:41

Not sure Bud

But have you got a mute button on your keyboard,turned on? Stopping midi messages

In reason preferences, have you allowed it to re scan your devices?

Also have you defragged your hard drive?

A few ideas.Im no expert on this stuff as such,or the keyboard,but thats what I would look out for

muzicalkat 2013-05-02 11:44

FIXED - Reason won't recognise midi keyboard.
 
Hi, thanks for your reply.

I have managed to fix the problem and am sharing what I did in case anyone is struggling with this :)

The problem was the M-Audio driver. Although the Evolution MK-449c is now an M-Audio legacy device and fully supported by them, the driver was confusing Reason (although Cubase etc was fine).

As the MK-449c is 'Class Compliant' I took a chance at uninstalling the recommended M-Audio driver and simply plugging in the keyboard and let Windows do its thing......and viola! It worked! Reason now sees and recognises it.

I hope this might help someone in the future :)

Cheers!!


All times are GMT +2. The time now is 10:50.