View Single Post
  #270  
Old 2012-12-07, 13:30
alternating.bit's Avatar
alternating.bit alternating.bit is offline
 
Join Date: Aug 2012
Posts: 599
I'm very happy with Reason 6.5, and with new Rack Extensions constantly popping up, my only request is please NO NOT allow RE's to be made for higher versions of Reason ONLY.

I can see it now: "this Rack Extension requires Reason version 7.5 and above" >.<

Of course, I know that's the ideal marketing model for a corporation. Not to mention later versions of Reason will probably prompt new Extensions based on the new features, but I guess I'm referring to BASIC INSTRUMENTS, and not more specific latter-version based upgrades, if that makes any sense. I was under the impression that Reason was going to stay at 6.5 longer while we keep shelling out cash for extensions, but I can't afford both software upgrades AND these fun new toys...
__________________
~alternatingbitmusic on YouTube~
VIKING | POLYSIX | PREDATOR | ANTIDOTE | PULSAR | CV SUITE