View Single Post
Old 2013-01-04, 01:41
Posts: n/a
Does Reason Block the Midi Signal to other PLugins?

My problem: Suddenly, when in ProTools 9, every plugin I have (with the exception of Reason) no longer seems to work with my midi controller. This started happening right after I installed Reason. Now, Reason is the only plugin that recognizes the signal from my midi controller. I need to use a different plugin (Xpand and Omnisphere) with my midi controller, but I believe Reason is somehow causing my other plugins to NOT recognize my midi controller.. I believe this because everything worked until I installed Reason. Ever since I installed Reason, nothing but Reason works with midi.

Has anyone else had this problem, if so how do you fix it?

ok now the break down:

Before I installed Reason, this is the exact procedure that worked perfectly"

1. I plugged the midi controller into the USB port
2. I opened protools and created an instrument track.
3. I clicked on the inserts section of the track channel and went MULTICHANNEL PLUGIN/ INSTRUMENTS/ XPANDER (or any other plugin)
4. The plugin (i.e. Xpander, Omnisphere, etc.) then opened up
5. I selected a sound from the plugins library, and started playing my midi controller.

it used to be that simple.

But ever since I installed Reason, this is what happens:

1. I plug in the midi controller into the USB port.
2. I open protools and create an instrument track.
3. I click on the inserts section of the instrument track and follow MULTICHANNEL PLUGIN/ INSTRUMENTS/ XPANDER (or any other plugin)
4. The plugin (i.e. xpander, omnisphere, whatever) opens up
5. I push the keys on my midi controller but NOTHING HAPPENS.

NO sound. NO green signal on the signal bar. Nothing.

HOWEVER, if I follow the same exact process and then follow MULTICHANNEL PLUGIN/ INSTRUMENTS/ REASON instead of any other plugin, everything works fine.

So clearly somehow REASON is usurping my midi signal even if it's not open.

NOw this is all the things Ive all ready tried to fix it:

1. I have gone into REASON and opened PREFERENCES/ KEYS AND CONTROLLERS and unchecked my midi controller from the list so that it is no longer enabled to be used in REASON. (I had hoped that if i disabled the midi controller in REASON, that the midi signal would work again in Omnisphere and the other plugins... assuming that Reason was somehow blocking any other plugin from receiving the midi signal.)

2. I have gone in ProTools to SETUP/ MIDI/ INPUT DEVICES to make sure that my midi controller (novation remote 25 LE) is listed and checked. It is.

3. I have tried various combinations of restarting and plugging in my hardwares. (i.e. turn everything off, then plug in midi controller, then turn on mbox, then turn on computer, then open protools VERSUS turn on mbox, then computer, then protools, then plug in midi controller, ETC.) to no avail.

4. I have followed in protools to SETUP/ PREFERENCES/ MIDI TAB but I found nothing there that seemed to have anything to do withthis. (unless you know something I don't know)

5. I dont remember the exact path, but I also found a menu that allowed me to select HUI and my novation... but i dont remember how i got there and it didnt work so i undid everything.

I only even mention REASON because I only started having a problem with my midi setup after I installed Reason. It always worked with other plugins before that, so I'm only assuming this issue has something to do with Reason. I suppose it might be entirely unrelated.

Meanwhile i have only a couple weeks to record and arrange amd mix and master this track and I really need to use my midi controller. If not for the fact that it works in Reason, I would just think my controller was broken. But it does, so it isnt.

Please please help me somebody.