Propellerhead Software
  #1  
Old 2012-11-18, 01:18
oddacorn oddacorn is offline
 
Join Date: Aug 2009
Posts: 43
Exclamation Mixer/Neptune Input Bug Found (6.5.2)

I found a bug in Reason today. I was trying to use a mixer as a switch to control what audio gets sent to a Neptune (I'm doing some experiments with audio to MIDI conversion and am trying to sort out what the heck Neptune's Pitch CV out is doing, because it's not just sending normal MIDI note values - not sure why, as that would seem to make obvious sense). Anyway, I've found that the audio Neptune receives doesn't respect the mixer settings, no matter the type of mixer device. If you mute a channel, Neptune still responds to the signal as if it weren't muted. To test things, I stuck a Spider Audio Splitter after the mixer's master output and routed one version of the signal to the Neptune and the other to a mixer channel. Muting the input shuts off the audio going to the mixer channel, but not to Neptune. Similarly, changes to the volume levels on the mixer have no effect on what Neptune is hearing.

I posted a song file that demonstrates this issue at https://dl.dropbox.com/u/1881605/Nep...t%20Bug.reason. I hope you'll take a look into this.

Thanks!
  #2  
Old 2012-11-18, 09:09
RXTX's Avatar
RXTX RXTX is offline
 
Join Date: May 2012
Posts: 562
Interesting find. I can also confirm that it happens in 6.5.1.

For now one workaround would be to use Thor as a muting mechanism (Audio In1 100% -> Audio Out1 scaled 100% by Button1). It seems multiplying the incoming audio by zero is the only surefire way to stop Neptune from tracking it.

By the way, Neptune's pitch CV isn't a note#, but a frequency. For example, you could connect it to OSC Pitch of a Subtractor.
  #3  
Old 2012-11-18, 16:19
MattiasHG's Avatar
MattiasHG MattiasHG is offline
Propellerhead
 
Join Date: Apr 2006
Posts: 2,429
We should clear up the difference between a mute and a mute here.

Muting in a mixer does just that, mutes the audio so you can't hear it. However, muting in the sequencer has a different way of working. Here we're muting the actual "data", audio/MIDI. Try muting Thor in the sequencer and you'll see that Neptune stops responding.

If you trying doing the same thing you did with Neptune with ANY device (MClass Compressor etc. etc.) you'll see that they all receive signal. You just can't hear it.

In other words: this is by design.
__________________
  #4  
Old 2012-11-18, 18:25
RXTX's Avatar
RXTX RXTX is offline
 
Join Date: May 2012
Posts: 562
Quote:
Originally Posted by MattiasHG View Post
Muting in a mixer does just that, mutes the audio so you can't hear it.
I guess the question is, what exactly does a 6:2 output when its channels are muted? When the output is connected to a Neptune, it doesn't register an input, yet somehow tracks it. How is that possible?

Instrument => 6:2 (muted) => Neptune
Here, Neptune's input LEDs are off, but tracking is on.

Instrument => 6:2 (muted) => Thor (multiply by 0) => Neptune
Here, Neptune's input LEDs are off, and tracking is off.
  #5  
Old 2012-11-19, 14:13
LudvigC's Avatar
LudvigC LudvigC is offline
Propellerhead
 
Join Date: Jan 2000
Posts: 534
Quote:
Originally Posted by RXTX View Post
I guess the question is, what exactly does a 6:2 output when its channels are muted? When the output is connected to a Neptune, it doesn't register an input, yet somehow tracks it. How is that possible?

Instrument => 6:2 (muted) => Neptune
Here, Neptune's input LEDs are off, but tracking is on.

Instrument => 6:2 (muted) => Thor (multiply by 0) => Neptune
Here, Neptune's input LEDs are off, and tracking is off.
This is a weird behavior, and I have reported it as a bug to be investigated.

thanks / LudvigC
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rewiring audio input Hypnotoad10 General Forum (read only) 4 2011-07-19 20:20
Any Saffire interface users? Record question/problem. roboticefx General Forum (read only) 7 2011-02-02 00:58
Rewire-No midi controller input? junedark General Forum (read only) 1 2010-08-21 14:42
Input gain levels jhsu1886 Phead User Forum (read only) 7 2010-05-04 18:27


All times are GMT +2. The time now is 00:11.