Propellerhead Software
  #1  
Old 2012-11-28, 13:24
cube's Avatar
cube cube is offline
 
Join Date: Mar 2002
Posts: 23
OSX trackpad behaviour

Hi

New OSX versions introduced what I feel is an awkward behaviour of the trackpad, the so called natural scrolling, which would be natural on a touch screen, but is totally illogical using a mouse or a trackpad..

The problem is that if I uncheck this option at an os level, Reason's behaviour doesn't follow, so that I'm finding myself uncomfortable with zooming in and out using gestures on mighty mouse or MBP trackpad..

Would it be possible to implement a switch to invert Reason's behaviour WRT this?

Thanks,

Tommaso
  #2  
Old 2012-11-28, 21:34
plaamook's Avatar
plaamook plaamook is offline
 
Join Date: Apr 2006
Posts: 1,222
what OS?

I'm on 10.7 and its fine.

wht i mean is that i've got it turned off in OSX and its off in Reason as well.

Last edited by plaamook; 2012-11-28 at 22:39.
  #3  
Old 2012-11-28, 22:29
KryoShift's Avatar
KryoShift KryoShift is offline
 
Join Date: Jul 2011
Posts: 448
How long have you been using Lion? I think that's when this was introduced?

I don't even notice anymore, though I HATED it when it first came out lol.
__________________
Reason 6.5
  #4  
Old 2012-11-28, 23:38
cube's Avatar
cube cube is offline
 
Join Date: Mar 2002
Posts: 23
I'm quite always up to date, apart from about a month to let big showstoppers come out.. I have turned it off, and scrolling in Reason follows this behaviour. it's command+two fingers drag with magic mouse or trackpad that doesn't make much sense to me: if i keep the "natural" scrolling setting then zooming is intuitive (to me at least: drag to the right => zoom in and drag down => zoom in vertical) otherwise it's zooming out when dragging to the right and out vertical when dragging down.. Is it just me? I know it's a matter of preference, but I feel like it's upside down.. Of course I can get used to it, but after three months or so spending a lot of time in front of Reason, I still find myself zooming the wrong way..


Sorry, I should have specified in original post that the problem here is about zooming, not about scrolling. I mean, Reason follows Os setting for scrolling, but in my opinion shouldn't follow OS behaviour when zooming. I hope I made myself clear..

Last edited by cube; 2012-11-28 at 23:41.
  #5  
Old 2012-11-28, 23:48
plaamook's Avatar
plaamook plaamook is offline
 
Join Date: Apr 2006
Posts: 1,222
i think its always been that way?

i didn't notice a change when i moved over to lion anyway. been a while now so i can't remember but i'm sure i didn't notice anything and i've had the screwy scrolling turned off since day 1.
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Record 1.0 - Strange behaviour, when using send effects on the SSL vectorlord Phead User Forum (read only) 11 2012-08-03 21:30
Magic Mouse or Magic Trackpad with Reason FailedMuso Phead User Forum (read only) 18 2012-07-06 09:04
*Step* behaviour of Note Off/On - Remote Overrides Sterievo Phead User Forum (read only) 0 2011-02-12 02:23


All times are GMT +2. The time now is 19:55.