Propellerhead Software

Go Back   Propellerhead Forum > General Forum (read only)

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #3  
Old 2013-03-09, 11:14
electricfusion's Avatar
electricfusion electricfusion is offline
 
Join Date: Oct 2007
Posts: 2,489
Hi,
it sounds like,just by reading your description,that the amount of reverb might be the "culprit".
It´s really hard to tell w/o actually listening to the track so if you´re up to send me the song file via PM and i´ll have a look at it.
Using a reverb for creative purposes is a pretty tricky task IMO as you,in general,have the tendency to add to much,if solo-ed, which sounds like something hit the fan in the mix later on.
Been there,done that.
__________________
I reject your reality and substitute my own!

http://soundcloud.com/electricfusion
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OT - Issues with Sound Cloud zillis Phead User Forum (read only) 0 2011-06-08 01:46
Sound bank issues Lomaiwe General Forum (read only) 2 2009-02-13 17:04
Sound Quality Issues - Exporting My Song drdubz General Forum (read only) 1 2008-08-30 00:33
review:All reason Synthesizer sound high end! wangyuechao General Forum (read only) 9 2007-10-15 21:04
Sound Issues taylorswa5 General Forum (read only) 5 2003-11-24 14:52


All times are GMT +2. The time now is 12:59.