Propellerhead Software
  #1  
Old 2013-05-16, 01:25
Kryger Kryger is offline
 
Join Date: Mar 2010
Posts: 15
Sound laggy using EMI

Sound is very delayed when i play my midi keyboard. So much, it's impossible tp record anything tight. How do I solve that?

Help much appreciated
  #2  
Old 2013-05-16, 03:54
Shawng101 Shawng101 is offline
 
Join Date: Sep 2009
Posts: 77
sound IS laggy when you are using external MIDI, that's an unfortunate fact of life, but it shouldn't be too bad. you leave out important info though:

Are you using an actual external synth (shouldn't be too laggy) or are you trying to route MIDI to a VST? (which, depending on how you do it can be extremely laggy) if it's the second thing, make sure your extra sound card, or Audio loopback program (Jack, Soundflower, ASIO4All) is set to use ASIO drivers and not windows native drivers.

what you can ultimately do about it in your finished project is either adjust the timing of the MIDI notes using the ReGroove Mixer's slide function, or record the synth output as Audio and drag the waveform into place in the sequencer. I like to play in parts live on my keyboard, and I find that when I do that, and record as audio, my subconscious musician brain is adjusting the timing for me, and it's not too bad, but if you program your stuff, you will need to adjust the timing after the fact.

Third option, there is an RE coming out that will analyze the lag, and make adjustments to the other tracks
  #3  
Old 2013-05-16, 04:04
selig's Avatar
selig selig is offline
 
Join Date: Jun 2003
Posts: 10,512
Quote:
Originally Posted by Kryger View Post
Sound is very delayed when i play my midi keyboard. So much, it's impossible tp record anything tight. How do I solve that?

Help much appreciated
Are you using a large buffer size on your audio interface? That can cause additional lag. :-)
__________________
Giles Reaves, aka 'selig'
Audio Illusionist, Musical Technologist
Selig Audio, LLC
USA
  #4  
Old 2013-05-16, 16:24
Kryger Kryger is offline
 
Join Date: Mar 2010
Posts: 15
Thanks for the replies guys!

I'm playing an actual synth - my old virus b rack - which sounds amazing! Guess I just have to accept to fight with the latency then.

I've tried to adjust the buffer size - it did help, but I still have to use the reGroove to reallt get things tight though.
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to mix to sound good no matter what speakers redanieru General Forum (read only) 2 2010-11-17 04:33
choppy, laggy sound after Record sits for a while Ixus Phead User Forum (read only) 11 2010-08-24 13:34
Does anyone know how to recreate this sound jlgrimes General Forum (read only) 0 2010-07-06 03:43
Getting a good Rhodes sound in Reason 3 ???????? imhotep General Forum (read only) 17 2007-05-26 19:09
Reproducing an instrument Alex General Forum (read only) 4 2004-01-06 22:10


All times are GMT +2. The time now is 03:36.