Propellerhead Software
Prev Previous Post   Next Post Next
  #1  
Old 2010-07-07, 01:39
highmarcs highmarcs is offline
 
Join Date: Jul 2007
Posts: 62
Unhappy Record Not Working For Me?

I've used Reason for quite some time but have only today tried to work with it inside of the Record Demo, since I'm contemplating maybe buying Record as a way out of my ReWire hell, since most of my sounds come from Reason.

I've run into some annoying and major issues in Record though. Could anyone clarify for me what I'm doing wrong, or if my problem stems from limitations in the Demo version of Record, or if that's just how Record works?

ISSUE 1.
I launch Record after Reason is running and I get a pop up telling me that I can't launch Record while Reason is running, shut down Reason and launch Record. I do that and try to open up Reason after Record is running and then get a pop up telling me that I can't open Reason While Record is running, shut down Record first and then launch Reason. Now I THOUGHT the two were supposed to play nice with each other, but I can't even get them to launch together. I've read that if you have Reason already, Record will auto launch with Reason integrated into it. I have yet to see this happen.

ISSUE 2.
Since I can't launch the two together, I open Record and import some MIDI stems. To my
chagrin, Record automatically loads each track with a separate ID8 module. ID8 doesn't have anything I need, so I would like to simply SWITCH those ID8 modules out for other Reason devices.

Now, funny thing is, even though, Record won't let me launch Reason with it, all of my Reason devices appear as options in Record. Still I can't find any way to simply swap out the ID8's for say…Combinators. That's right. There is is no “change device or replace device with...” option when I right click on an ID8.

So, I figure I'll have to CREATE NEW Combinators and then delete the ID8's.
Well, I come to find out that there is no way to just delete the ID8's. I am only offered the option of deleting the device AND THE ASSOCIATED TRACKS! So…I'm FORCED to use ID8 sounds on my stems or nothing?

Hmm…as a workaround, I finally MANUALLY drag each clip down into the new Combi tracks I've made, thus leaving the ID8 tracks empty. Then I'm able to safely delete the ID8's and accept the FORCED track deletion.

This works I guess, but it seems REALLY convoluted and primitive. I mean, there is no way to simply swap out a device in Record? There's no way of selecting say and ID8, right clicking on it and selecting “change to or replace this device with...”?
Really?
REALLY?

I could never transfer all of my projects into Record if things work this way. It's simply not practical. It's easier to just stay in my other DAW and Rewire Reason (imagine that) than having to always manually drag clips down into new tracks and then delete default ID8 tracks that I don't need.

ISSUE 3.
I try to open an existing Reason project of mine in Record and well… there seems to be no option for that?…Huh?... How does that jive with Reason being FULLY integrating into Record?

ISSUE 4.
I tried to overlay one clip with MIDI data on top of another clip with MIDI data and Record seems only capable of displaying and letting me work on the data in the clip that's on top. In my other DAW, I often place clips on top of each other to line things up and then I drag those clips back down to their own track. Sometimes I do this because I'll play or program a part in, in pieces. Then I overlay the clips and merge that data all into one clip. Is there a setting in Record that allows this kind of editing?

ISSUE 5.
On top of all that, at some point, I lost my transport bar? It's just GONE. I've tried "bring all to front", I've tried every thing in the the "window" tab and there is no option for "show transport"? Really? Does anyone know where it went? Is this a bug in Record?
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Long Live The New DAW King! BeatmakerEI Phead User Forum (read only) 138 2010-06-03 23:37
Line 6 Amps - interesting function speculations platzangst Phead User Forum (read only) 6 2010-02-21 19:07
Record Workflow, using Record with other equipment COCPORN Phead User Forum (read only) 17 2010-01-02 15:19
Problem with authorization of Record for Reason Owners. DannyTaki Phead User Forum (read only) 5 2009-11-22 09:24


All times are GMT +2. The time now is 11:13.