View article

Article

I'm not allowed to download the Reason 3.0.4 update. Why?

To be allowed to download the Reason 3.0.4 update, you must first register a copy of Reason 3.0 to your user account.

Please note that there is a difference between Reason and Reason Adapted - if you are a Reason Adapted user, you need to look for the Reason Adapted update (only available to owners of certain versions of Reason Adapted).

If you have registered your copy of Reason 3.0 to your user account but still can't download the 3.0.4 update, you may be experiencing problems with a faulty cookie. Please delete any Propellerhead related cookies, restart your browser and try again.

Was this article helpful?

Email support

There is no email support available for the selection you have made.

Search

Free text search: